If you are starting to get a cluttered model space in your Rails application you should consider placing your models in a namespace. As an example I’m going to go through a Rails application I’m calling Recipes. If my models were starting to have the namespace implied in the class names such as AppleFruit in app/models/apple_fruit.rb then that’s starting to smell like rotten apples. A better names