Tips on naming boolean variables - Cleaner Code Published 10/3/2019 There is a convention to prefix boolean variables and function names with "is" or "has". You know, something like isLoggedIn, hasAccess or things like that. But throughout my career I have seen and written code where this convention was just thrown out the window. So let's check out some of these edge cases. As with all rules, the